*

【Ruby on Rails 備忘録】bundle install 時のエラー「An error occurred while installing nokogiri (1.6.8)」の解決方法

Ruby on Rails で 

bundle install したときに、こんなエラーが出て、ハマったので備忘録

(Mac OS X El Capitan 10.11.4、Ruby 2.1.3)

 

 

An error occurred while installing nokogiri (1.6.8), and Bundler cannot

continue.

Make sure that gem install nokogiri -v '1.6.8' succeeds before bundling.

 

 

 

いろいろググって調べると、Qiitaで解決しました。

 

OS X Yosemite で Nokogiri gem を bundle install

http://qiita.com/dtan4/items/34c9ebd5ce7bfa0f133b

 

 

以下のコマンドを打てば、エラーなく通りました。

 

$ gem update –system

$ xcode-select –install

$ bundle config build.nokogiri –use-system-libraries

$ bundle install


 

 

 

ありがとうございました。






ad

    この記事が気に入りましたら、ぜひTwitter、facebookボタンをお願いします。
    ブログを書くモチベーションになります。よろしくお願いします。

  • このエントリーをはてなブックマークに追加
この記事が良かったらビットコインで寄付をお願いします。
ビットコイン投げ銭ウィジェット



関連記事

【Ruby on Rails 備忘録】Errno::ECONNREFUSED: Connection refused – connect(2) for action mailer の解決方法

      Ruby on Railsで WEBサービスを作成中。   コメントがあったら

記事を読む

【Ruby on Rails 備忘録】Herokuを使ってWEBに公開する

      Ruby on Railsで作ったアプリケーションをHerokuでWEBに公開

記事を読む

【Ruby on Rails 備忘録】Herokuを使って公開中のアプリを更新する

        前回のブログ 【Ruby on Rails 備忘録】Herokuを使ってWEBに公開

記事を読む

【Ruby on Rails 備忘録】LINE Messaging API でチャットボットを作る

    毎回悩むので自分用の備忘録として保存します。   なお、ほとんどが、こちらの方の記事を参考

記事を読む

漢字を教えてくれるLINEのチャットボット「KANJI」を作りました。

    漢字を教えてくれるLINEのチャットボット「KANJI」を作りました         これは

記事を読む

ad

Message

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

ad

京都をブラタツヤ

      ちょっと古い話ですが、 8月24日に京都に行ってきました。

『ワンス・アポン・ア・タイム・イン・ハリウッド』を観て(ネタバレあり)

        久しぶりにタランティーノ映画を観た。   ネタや伏線

NeoPixelでアイアンマンのようなものを作ったよ

前回の投稿の光るSDGsバッジを作って、SNSに投稿したら、ある人か

NeoPixelで光るSDGsバッジ作ったよ

    最近、こんなバッジ付けてる人、よく見かけますね。

レッドハッカソンひろしま2019

          プロローグ   広島では毎年、広島県主催の「レッ

→もっと見る

    • 744180総閲覧数:
    • 40今日の閲覧数:
    • 961昨日の閲覧数:
    • 0現在オンライン中の人数:
    • 2014年4月29日カウント開始日:
PAGE TOP ↑